Spade set updates

* indicates required